Cluster A Mailstore Disabled
Incident Report for Without Code
Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 06:25 PST
Investigating
One of our mailstores on HostedEmail cluster A has been disabled due to maintenance work. Inboxes on this mailstore will be inaccessible until work is completed.
Posted Nov 13, 2024 - 21:00 PST
This incident affected: Email.