A fix has been implemented for this issue. We're monitoring the results now.
Posted Nov 19, 2024 - 12:53 PST
Update
We are getting reports that IMAP and POP services are also affected. Please standby while we continue to investigate.
Posted Nov 19, 2024 - 12:14 PST
Update
We are continuing to investigate this issue.
Posted Nov 19, 2024 - 12:14 PST
Investigating
We are investigating an issue preventing some users on Cluster A from logging into Webmail. HostedEmail is experiencing issues resulting in delayed access to webmail. IMAP and POP services are unaffected. Our engineering team has been engaged.
We will provide an update once we have additional information