We are continuing to monitor for any further issues.
Posted Nov 14, 2024 - 20:51 PST
Monitoring
Our email team has applied a fix for the earlier issues, and all impacted services appear to be restored. We will continue to monitor this incident and provide any further updates. Thank you for your patience.
Posted Nov 14, 2024 - 20:28 PST
Update
We are continuing to investigate this issue.
Posted Nov 14, 2024 - 15:12 PST
Investigating
We are currently receiving an increasing number of reports from users experiencing webmail login/loading failures. Our engineering team is actively investigating the issue. We'll provide more updates as they become available.