Email – Degraded Performance
Incident Report for
Without Code
Resolved
This incident has been resolved.
Posted
Nov
11
,
2024
-
15:40
PST
Update
Our engineers continue to investigate this matter impacting a small subset of users.
Posted
Nov
11
,
2024
-
14:06
PST
Investigating
We are investigating an issue preventing some users on Cluster A from accessing their accounts. Our engineering team has been engaged.
We will provide an update once we have additional information.
Posted
Nov
11
,
2024
-
12:36
PST
This incident affected: Email.
×
Subscribe to Incident
Subscribe to updates for
Email – Degraded Performance
via . You'll receive .